aboutsummaryrefslogtreecommitdiff
path: root/etc/debian/rules
diff options
context:
space:
mode:
authorPatrick Spek <p.spek@tyil.nl>2022-08-25 08:26:44 +0200
committerPatrick Spek <p.spek@tyil.nl>2022-08-25 08:26:44 +0200
commit98768c0ca446f3202ce4d3e79eb68e463f11c156 (patch)
tree25253773f911ccc265757fdd2daac810c899b033 /etc/debian/rules
parent3b308831086d44c38da3e54f7c3ed514bd19e785 (diff)
Overhaul Debian package generation
Diffstat (limited to 'etc/debian/rules')
-rwxr-xr-xetc/debian/rules29
1 files changed, 29 insertions, 0 deletions
diff --git a/etc/debian/rules b/etc/debian/rules
new file mode 100755
index 0000000..8750992
--- /dev/null
+++ b/etc/debian/rules
@@ -0,0 +1,29 @@
+#!/usr/bin/make -f
+# See debhelper(7) (uncomment to enable)
+# output every command that modifies files on the build system.
+#export DH_VERBOSE = 1
+
+
+# see FEATURE AREAS in dpkg-buildflags(1)
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+# see ENVIRONMENT in dpkg-buildflags(1)
+# package maintainers to append CFLAGS
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+# package maintainers to append LDFLAGS
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+
+%:
+ dh $@
+
+install:
+ make PREFIX="debian/bashtard" DESTDIR=/usr install
+ make PREFIX="debian/bashtard" man
+
+
+# dh_make generated override targets
+# This is example for Cmake (See https://bugs.debian.org/641051 )
+#override_dh_auto_configure:
+# dh_auto_configure -- \
+# -DCMAKE_LIBRARY_PATH=$(DEB_HOST_MULTIARCH)