summaryrefslogtreecommitdiff
path: root/data.d/etc-nixos/env/global.nix
diff options
context:
space:
mode:
Diffstat (limited to 'data.d/etc-nixos/env/global.nix')
-rw-r--r--data.d/etc-nixos/env/global.nix54
1 files changed, 54 insertions, 0 deletions
diff --git a/data.d/etc-nixos/env/global.nix b/data.d/etc-nixos/env/global.nix
new file mode 100644
index 0000000..6ea9db4
--- /dev/null
+++ b/data.d/etc-nixos/env/global.nix
@@ -0,0 +1,54 @@
+{ config, pkgs, ... }:
+
+{
+ boot = {
+ supportedFilesystems = [ "zfs" ];
+ zfs = {
+ forceImportRoot = false;
+ };
+ };
+
+ environment = {
+ systemPackages = with pkgs; [
+ borgbackup
+ git
+ gnupg
+ jq
+ mosh
+ silver-searcher
+ tmux
+ vim
+ ];
+ };
+
+ i18n = {
+ defaultLocale = "en_US.UTF-8";
+ };
+
+ networking = {
+ domain = "tyil.net";
+ };
+
+ services = {
+ openssh = {
+ enable = true;
+ };
+ };
+
+ system = {
+ copySystemConfiguration = true;
+ };
+
+ time = {
+ timeZone = "Europe/Amsterdam";
+ };
+
+ users = {
+ users = {
+ tyil = {
+ isNormalUser = true;
+ extraGroups = [ "wheel" ];
+ };
+ };
+ };
+}